Code

Opened 4 years ago

Closed 4 years ago

#14326 closed (duplicate)

packages not properly decoupled from project in tutorial

Reported by: bestform <webmaster@…> Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords: decoupling urlconf packages
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

On http://docs.djangoproject.com/en/dev/intro/tutorial03/ you write about decoupling the urlconfs. The package you use in the decoupled urlconf still has the project name in it, which in my opinion it shouldn't, because it wouldn't be decoupled properly this way.
The same is true for the import of the Poll model earlier, where you use from mysite.polls.models import Poll instead of the relative form from models import Poll.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14216, #13865, #13507, #12126, #11464, #11424, #11172, #10081, #9860, #9767, #7709, #7660, #7650, #7443, #5283, #4087 and #3941.

We know about this issue, but it's not as simple as just removing a prefix. We need to do a tutorial rewrite to properly introduce the idea of reusable apps.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.