Code

Opened 4 years ago

Closed 4 years ago

#12126 closed (duplicate)

Tutorial part 3: "Decoupling the URLconfs" looks weird (doesn't really decouple)

Reported by: Bjoern Owned by: nobody
Component: Documentation Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the tutorial it says:

Now that we've decoupled that, we need to decouple the 'mysite.polls.urls' URLconf by removing the leading "polls/" from each line, and removing the lines registering the admin site:

urlpatterns = patterns('mysite.polls.views',
...

This seems weird to me, because with "mysite.polls.views", the app still seems to be tightly coupled to the project ("mysite"). I could be mistaken, though - only just learning Django.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #3941, and about a dozen others. Please search trac before filing a new bug.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.