Code

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9767 closed (duplicate)

tutorial part 3 - Decoupling the URLconfs - module correction

Reported by: rduplain Owned by: nobody
Component: Uncategorized Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the tutorial part 3, Decoupling the URLconfs, urlpatterns should point to polls.views not mysite.polls.views, e.g.

urlpatterns = patterns('polls.views',
    (r'^$', 'index'),
    (r'^(?P<poll_id>\d+)/$', 'detail'),
    (r'^(?P<poll_id>\d+)/results/$', 'results'),
    (r'^(?P<poll_id>\d+)/vote/$', 'vote'),
)

Leaving it at mysite.polls.views would not fully decouple the URLconf.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

In the future, please search for existing tickets before filing new ones.

Duplicate of #7209, #7660, #7442.

comment:2 Changed 6 years ago by rduplain

My apologies. I did search, but apparently didn't see those tickets. I see them now, thank you.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.