Code

Opened 5 years ago

Closed 5 years ago

#11172 closed (duplicate)

"Decoupling the URLconfs" isn't exactly true

Reported by: yacoob Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

http://docs.djangoproject.com/en/dev/intro/tutorial03/#intro-tutorial03 - the part about decoupling is not entirely right. During previous steps user put templates for polls app into global template directory. To make sure polls is fully decoupled, we should have put the templates in app's template directory.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by yacoob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

...and a question on top of that - 'polls/urls.py' still contains a reference to 'mysite' name. Shouldn't tutorial show how to write a truly independent app, without such things?

comment:2 Changed 5 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10081, #9860, #9767, #7709, #7660, #7650, #7443, #5283, #4087 and #3941. In the future, please search for existing tickets before filing new ones.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.