Code

Opened 4 years ago

Closed 4 years ago

#13865 closed (duplicate)

decoupling app from project in tutorial part 3

Reported by: Ralf Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords: documentation, tutorial, URLconf
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

At the end of the tutorial, part 3, there is an example of decoupling the app "polls" from the project "mysite".
The URLconf-pattern is written as

urlpatterns = patterns('mysite.polls.views',

This way, the app ist still coupled to the project. I tried

urlpatterns = patterns('polls.views',

and it works!
If this a feature, you should document this in the tutorial and in the URlDispatcher

Thanks for the great product Django

Ralf

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13507, #12126, #11464, #11424, #11172, #10081, #9860, #9767, #7709, #7660, #7650, #7443, #5283, #4087 and #3941.

We know about this issue, but it's not as simple as just removing a prefix. We need to do a tutorial rewrite to introduce the idea of reusable apps.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.