Opened 3 years ago

Closed 14 months ago

Last modified 14 months ago

#18108 closed New feature (fixed)

Official translations of the documentation

Reported by: survaes@… Owned by: nobody
Component: Documentation Version:
Severity: Normal Keywords: documentation translation
Cc: hirokiky@… Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

In the docs, the url is prefixed by en/version, if i change to another language i found 404 pages.

I think this point is important and that many tranlators have stopped theirs job because they are not published (if you show this page wiki1 and this other wiki2), you can see that many efforts have been made.

I take this report as blocked, because i think that for too much developpers, don't to read docs in theirs language is blocking. For me even if i can read and write english, i read and write slowly than in my mother language. For coding this is a little problem (signs are near math formulas), for docs, this is a strong problem, as you read many sentences in shorts times.

To conclude my questions are :

  • Is it possible with actual system to publish translation.
  • If yes :
    • when django will permit to send translations and to publish them?
    • where? (svn, git, a special django system...)
    • what will be the translation process? acceptance - failover...

If this is possible, i will participates and many others. Be sure that this interessests many people.

Whatever your answer, thanks for your works, this site is so clear and django is a powerfull framework.

Best Regard,

Nicolas

Attachments (2)

docs_translation.diff (4.2 KB) - added by claudep 3 years ago.
Draft of build instructions
18108.diff (1.6 KB) - added by timo 14 months ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 3 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Severity changed from Release blocker to Normal

Technically this isn't a release blocker. It sounds more like a social issue that a code issue, too.

Changed 3 years ago by claudep

Draft of build instructions

comment:2 Changed 3 years ago by claudep

  • Component changed from Djangoproject.com Web site to Internationalization
  • Has patch set
  • Patch needs improvement set
  • Triage Stage changed from Unreviewed to Accepted
  • Type changed from Uncategorized to New feature

We are very close to a working process for translating the Django documentation. Just attaching a work-in-progress patch to share my experiments until now.

comment:3 Changed 3 years ago by claudep

I published a workflow proposal on a wiki page: TranslatingDocumentation

Please read and review/comment.

comment:4 Changed 3 years ago by timo

  • Component changed from Internationalization to Documentation
  • Summary changed from Where are translations for docs to Official translations of the documentation

Marking #8940 as a duplicate of this ticket since this one has more recent activity.

comment:5 follow-up: Changed 3 years ago by jezdez

I've reviewed the TranslatingDocumentation page and agree with it, although have a few questions:

What do we need to modify in the djangoproject.com code to search the different languages?
When do we pull the changes from Transifex?

comment:6 in reply to: ↑ 5 Changed 3 years ago by claudep

Replying to jezdez:

What do we need to modify in the djangoproject.com code to search the different languages?

Oh well, I didn't think about that. Probably we should create a different search index for each language. I will add a note on the Wiki.

When do we pull the changes from Transifex?

This is still undecided, might be once a week, for example. It depends also on the automation we'll achieve with the whole process.

comment:7 Changed 2 years ago by claudep

Git repo: https://github.com/django/django-docs-translations
Transifex project: https://www.transifex.com/projects/p/django-docs/

The question arose about sharing translation teams with Django Transifex. Mixing 17185 translatable strings (344891 words) in django-docs with django's 3042 words would make translation stats looks imbalanced. The current feeling is to not share teams (small overhead to manage 2 different team sets).

comment:8 Changed 2 years ago by claudep

Anyone at ease with writing Makefiles to create one to compile po files into mo files in https://github.com/django/django-docs-translations ?

comment:9 Changed 2 years ago by hirokiky

  • Cc hirokiky@… added

I sent a pull-request adding a Makefile to compile po files into mo files.

https://github.com/django/django-docs-translations/pull/1

comment:10 Changed 2 years ago by hirokiky

I want to use machine translation on Web interface of Transifex.
But, I'm not have a permission to change the setting of this project (https://www.transifex.com/projects/p/django-docs/).

Would someone set the cooperation to translation service?

comment:11 Changed 2 years ago by jezdez

@hirokiky I've just enabled the Google machine translation ability (with my personal account).

comment:12 Changed 2 years ago by hirokiky

@jezdez Thank you!

comment:13 Changed 14 months ago by timo

  • Has patch unset
  • Patch needs improvement unset

I think the main task is to increase visibility of the translation documentation (#22061), but I'll leave this open for Claude to confirm.

comment:14 Changed 14 months ago by claudep

Timo, shouldn't we complement the https://docs.djangoproject.com/en/dev/internals/contributing/localizing page about documentation translation? I would write something like this, but feel free to rewrite it in a better English.

Documentation
=============
There is also the opportunity to translate the documentation, even if this is a huge work to complete entirely
(you have been warned!). We use the same Transifex tool, but at this URL: https://www.transifex.com/projects/p/django-docs/.
The translation will appear on the docs.djangoproject.com Web site as soon as at least the ``intro`` part is
fully translated in your language.

Changed 14 months ago by timo

comment:15 Changed 14 months ago by timo

  • Has patch set

Looks good, revisions attached.

comment:16 Changed 14 months ago by claudep

  • Triage Stage changed from Accepted to Ready for checkin

Great (as usual). Please commit and close the ticket.

comment:17 Changed 14 months ago by Tim Graham <timograham@…>

  • Resolution set to fixed
  • Status changed from new to closed

In 1a3bec4a26248f93982e0349bab53adaab80e968:

Fixed #18108 -- Added instructions for translating documentation.

Thanks Claude Paroz.

comment:18 Changed 14 months ago by Tim Graham <timograham@…>

In 0b2a36ecf787620ff96c6a342c11a9c39bcfc41b:

[1.7.x] Fixed #18108 -- Added instructions for translating documentation.

Thanks Claude Paroz.

Backport of 1a3bec4a26 from master

Note: See TracTickets for help on using tickets.
Back to Top