Code

Opened 6 years ago

Closed 6 years ago

#7997 closed (fixed)

./manage.py <command> --help shows manage.py help message

Reported by: trevor Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Steps to reproduce:

./manage.py runserver -h

Expected output:

Usage: ./manage.py runserver [options] [optional port number, or ipaddr:port]

Starts a lightweight Web server for development.

Options:
  --settings=SETTINGS   The Python path to a settings module, e.g.
                        "myproject.settings.main". If this isn't provided, the
                        DJANGO_SETTINGS_MODULE environment variable will be
                        used.
  --pythonpath=PYTHONPATH
                        A directory to add to the Python path, e.g.
                        "/home/djangoprojects/myproject".
  --traceback           Print traceback on exception
  --noreload            Tells Django to NOT use the auto-reloader.
  --adminmedia=ADMIN_MEDIA_PATH
                        Specifies the directory from which to serve admin
                        media.
  --version             show program's version number and exit
  -h, --help            show this help message and exit

Actual output:

Usage: manage.py [options]

Options:
  --settings=SETTINGS   The Python path to a settings module, e.g.
                        "myproject.settings.main". If this isn't provided, the
                        DJANGO_SETTINGS_MODULE environment variable will be
                        used.
  --pythonpath=PYTHONPATH
                        A directory to add to the Python path, e.g.
                        "/home/djangoprojects/myproject".
  --traceback           Print traceback on exception
  --version             show program's version number and exit
  -h, --help            show this help message and exit
Usage: ./manage.py runserver [options] [optional port number, or ipaddr:port]

Starts a lightweight Web server for development.

Options:
  --settings=SETTINGS   The Python path to a settings module, e.g.
                        "myproject.settings.main". If this isn't provided, the
                        DJANGO_SETTINGS_MODULE environment variable will be
                        used.
  --pythonpath=PYTHONPATH
                        A directory to add to the Python path, e.g.
                        "/home/djangoprojects/myproject".
  --traceback           Print traceback on exception
  --noreload            Tells Django to NOT use the auto-reloader.
  --adminmedia=ADMIN_MEDIA_PATH
                        Specifies the directory from which to serve admin
                        media.
  --version             show program's version number and exit
  -h, --help            show this help message and exit

The problem seems to originate in LaxOptionParser.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Closing and marking as a duplicate of of #6017, just like it was done with #6817.

comment:2 Changed 6 years ago by trevor

  • Resolution duplicate deleted
  • Status changed from closed to reopened

As noted in http://code.djangoproject.com/ticket/6017#comment:6, this is a separate issue. #6817 was reported and closed long before [7888] was committed. As of [8128], this bug is still present.

comment:3 Changed 6 years ago by russellm

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [8228]) Fixed #8120, #7997 -- Cleaned up the help messages displayed by django-admin so that the lax options aren't repeated, and the lax options are displayed when no subcommand is provided. Thanks to Scott Moonen <smoonen@…> and trevor for the respective reports.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.