Code

Opened 6 years ago

Closed 6 years ago

#6817 closed (duplicate)

Django's manage.py --help command outputs both generic and specific help if you switch the order of statements

Reported by: shanx Owned by: nobody
Component: Core (Management commands) Version: master
Severity: Keywords: sprint-pycon08
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using manage.py with: ./manage.py --help [command] gives you the [command] specific help as expected. But doing it the other way around: ./manage.py [command] --help gives you both the generic manage.py help output _and_ the specific [command] help.

For example:

(trunk)shanx@shanx:~/django/djangosprint-pycon2008/trunk/myproject $ ./manage.py loaddata --help
Usage: manage.py [options]

Options:
  --settings=SETTINGS   The Python path to a settings module, e.g.
                        "myproject.settings.main". If this isn't provided, the
                        DJANGO_SETTINGS_MODULE environment variable will be
                        used.
  --pythonpath=PYTHONPATH
                        A directory to add to the Python path, e.g.
                        "/home/djangoprojects/myproject".
  --traceback           Print traceback on exception
  --version             show program's version number and exit
  -h, --help            show this help message and exit
Usage: ./manage.py loaddata [options] fixture [fixture ...]

Installs the named fixture(s) in the database.

Options:
  --settings=SETTINGS   The Python path to a settings module, e.g.
                        "myproject.settings.main". If this isn't provided, the
                        DJANGO_SETTINGS_MODULE environment variable will be
                        used.
  --pythonpath=PYTHONPATH
                        A directory to add to the Python path, e.g.
                        "/home/djangoprojects/myproject".
  --traceback           Print traceback on exception
  --verbosity=VERBOSITY
                        Verbosity level; 0=minimal output, 1=normal output,
                        2=all output
  --version             show program's version number and exit
  -h, --help            show this help message and exit

Not really sure if this is a bug, or if this behaviour is meant this way. But thought I report it anyway.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by shanx

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of a more general issue covered by #6017. Closing my own ticket :)

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.