Opened 7 years ago

Closed 7 years ago

#5626 closed (wontfix)

Mac OS X permissions command could be more succinct.

Reported by: blinks@… Owned by: mboersma
Component: Documentation Version: master
Severity: Keywords: terminal Mac OS X
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by mboersma)

In the Mac OSX Permissions box (at the top of Creating a Project), there is some text suggesting a possible permissions solution:

... To do this, open Terminal.app and navigate (using the cd command) to the directory where django-admin.py is installed, then run the command chmod +x django-admin.py.

This line could be made quicker and easier by replacing "and navigate... ." with "and run the command chmod +x `which django-admin.py`." This removes the work involved in locating the installation directory, making it a little less painless, and makes the fix a one-step process. It will also guarantee that the correct django-admin.py is modified.

Possible problem: Backticks can be difficult to recognize in some fonts, but monospace fonts usually show them correctly. The user will most likely copy and paste the command anyway, making this issue moot.

Attachments (1)

5626.diff (961 bytes) - added by mboersma 7 years ago.
Fixes typo, shortens command to make django-admin.py executable

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by mboersma

Fixes typo, shortens command to make django-admin.py executable

comment:1 Changed 7 years ago by mboersma

  • Has patch set
  • Keywords Mac OS X added
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to mboersma
  • Patch needs improvement unset
  • Status changed from new to assigned
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 7 years ago by mboersma

  • Summary changed from Mac OSX Permissions, command could be more succinct. to Mac OS X typo, permissions command could be more succinct.

comment:3 follow-up: Changed 7 years ago by ubernostrum

  • Triage Stage changed from Ready for checkin to Design decision needed

Using which assumes the user has successfully gotten django/bin into the PATH, which isn't necessarily a safe assumption.

comment:4 in reply to: ↑ 3 Changed 7 years ago by anonymous

Replying to ubernostrum:

Using which assumes the user has successfully gotten django/bin into the PATH, which isn't necessarily a safe assumption.

It is if they followed the previous instructions: python setup.py install places scripts in the path on OSX. However, even if they hadn't, the pull-out assumes that they have. (The first sentence ends with "... when you try to run django-admin.py startproject," which doesn't tell them where that script might be, if they don't already know.) It also doesn't help the user find that directory (django/bin), which could be difficult if it's installed into some random site-packages directory.

comment:5 Changed 7 years ago by mboersma

The tutorial context already implies django-admin.py is on the search PATH. If that's not a safe assumption, more of the tutorial needs to be changed. Otherwise, this patch seems sane to me. Let's fix the "Max OS X" typo at least.

comment:6 Changed 7 years ago by mboersma

(In [6535]) Fixed #5633, refs #5626: Change "Max OS X" to "Mac OS X" in tutorial01.

comment:7 Changed 7 years ago by mboersma

  • Description modified (diff)
  • Summary changed from Mac OS X typo, permissions command could be more succinct. to Mac OS X permissions command could be more succinct.

This was really two bugs if we're being pedantic, so I fixed the "Max OS X" typo separately and changed the description to focus on the "chmod +x which django-admin.py" issue.

comment:8 Changed 7 years ago by derelm

Will all this work without sudo-ing? Just a thought…

comment:9 Changed 7 years ago by ubernostrum

  • Resolution set to wontfix
  • Status changed from assigned to closed

I think I'm just going to punt this; there's really not a bug here, and what remains is basically a bikeshed argument.

Note: See TracTickets for help on using tickets.
Back to Top