Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2647 closed defect (duplicate)

Error when changing ManyToManyField referencing "self" with raw_id_admin

Reported by: dart@… Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When a model field is defined as follows:

subcomponents = models.ManyToManyField("self", blank=True, null=True,

symmetrical=False,
#raw_id_admin=True, # <- Django bug activated: raw on "self" broken
)

(with the comment removed) the admin interface will raise an ObjectNotFound exception when you edit an object of this type (and you don't have to change this particular field).

I narrowed it down through trial-and-error to that combination of parameters.

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Appears to be a duplicate of #1816; fix for raw_id_admin was added in #3858/#3859.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.