Opened 9 years ago

Closed 9 years ago

#2648 closed enhancement (duplicate)

Bi-directional edits of ManyToMany fields in admin

Reported by: sh@… Owned by: adrian
Component: contrib.admin Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


In certain situations, it makes sense to be able to edit a ManyToMany relation in both of the datatypes' admin pages. I propose adding an extra keyword argument to ManyToManyField that makes it appear as though both of the datatypes has the manytomany relation.

Use case:
In my case, I have a bunch of categories and a bunch of items. Items can be in any number of categories and a category can contain any number of items.

If I'm creating a new item and already know that it belongs in categories a, b, and c, I should not have to open each of those categories to add the item to them.
On the other hand, I might be creating a new category and know that items x, y, and z belongs in it, I shouldn't need to open each of x, y, and z to add them to the categories.
With the current limitations, I can only have one of the above.

Change History (3)

comment:1 Changed 9 years ago by anonymous

I'd really like to see this implemented as well.

comment:2 Changed 9 years ago by anonymous

Identical to ? I would really like this too.

comment:3 Changed 9 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Yes I would say so. Closing as duplicate of #897.

Note: See TracTickets for help on using tickets.
Back to Top