Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#12403 closed (fixed)

Syndication feeds as class-based views

Reported by: Ben Firshman Owned by: Ben Firshman
Component: contrib.syndication Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Instead of using the crufty and limited feed_dict, instances of Feed classes can be used as views.

Attached patch fixes #6188, #6304, #6618, #6969, #8758, #8989, #10334, #11069 and #11973. It is fully backwards compatible. Some depreciated behaviour is still used in GeoDjango, but as designed, it still works fine for now.

Attachments (6)

syndication-views-1.diff (66.1 KB) - added by Ben Firshman 7 years ago.
syndication-views-2.diff (70.3 KB) - added by Ben Firshman 7 years ago.
Added missing templates and tests, and added pending depreciation warnings
syndication-views-3.diff (73.8 KB) - added by Ben Firshman 7 years ago.
Release notes and new deprecation warnings
syndication-views-4.diff (74.9 KB) - added by Ben Firshman 7 years ago.
Better docs
syndication-views-5.diff (75.4 KB) - added by Ben Firshman 7 years ago.
Applies cleanly against r12313 and improved documentation a little
syndication-view-6.diff (75.6 KB) - added by Ben Firshman 7 years ago.
Turns out "mailto:" test needs fixing and isn't against the RSS spec

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Ben Firshman

Attachment: syndication-views-1.diff added

Changed 7 years ago by Ben Firshman

Attachment: syndication-views-2.diff added

Added missing templates and tests, and added pending depreciation warnings

Changed 7 years ago by Ben Firshman

Attachment: syndication-views-3.diff added

Release notes and new deprecation warnings

Changed 7 years ago by Ben Firshman

Attachment: syndication-views-4.diff added

Better docs

comment:1 Changed 7 years ago by Jannis Leidel

Triage Stage: UnreviewedAccepted

Changed 7 years ago by Ben Firshman

Attachment: syndication-views-5.diff added

Applies cleanly against r12313 and improved documentation a little

Changed 7 years ago by Ben Firshman

Attachment: syndication-view-6.diff added

Turns out "mailto:" test needs fixing and isn't against the RSS spec

comment:2 Changed 7 years ago by Russell Keith-Magee

Resolution: fixed
Status: newclosed

(In [12338]) Fixed #6188, #6304, #6618, #6969, #8758, #8989, #10334, #11069, #11973 and #12403 -- Modified the syndication framework to use class-based views. Thanks to Ben Firshman for his work on this patch.

comment:2 Changed 5 years ago by Jacob

milestone: 1.2

Milestone 1.2 deleted

Note: See TracTickets for help on using tickets.
Back to Top