Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#8039 closed (fixed)

Incompatibillity with extra and order_by in some cases

Reported by: beiske@… Owned by: mtredinnick
Component: Database layer (models, ORM) Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The problem is however fixed by a side effect in as_sql(). Dont know exactly how to best describe this, but I've included a code-sample.

Attachments (1)

bug.py (1.4 KB) - added by anonymous 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by anonymous

comment:1 Changed 7 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8191.

comment:2 Changed 7 years ago by mtredinnick

  • milestone set to 1.0
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Unreviewed to Accepted

Reopening, since this really is a separate issue to parameter handling in extra(), which is the topic of #8191 and I don't want that ticket to become the dumping ground for all things extra-related.

comment:3 Changed 7 years ago by mtredinnick

  • Owner changed from nobody to mtredinnick
  • Status changed from reopened to new

comment:4 Changed 7 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [8429]) Fixed #8039 -- Make sure that extra(tables=...) tables are always included in
the resulting SQL. Previously, an optimisation was removing them in some corner
cases.

comment:5 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top