Opened 8 years ago

Closed 8 years ago

#7067 closed (invalid)

Form generated by form_for_model has bad html input tag.

Reported by: morfeus Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


Viewing the source in Safari 3.1.1 and FireFox shows the following:
<p><input type="submit" value"Submit"></p>

This page is generated by form_for_model.

The missing equals sign in 'value"Submit' causes FF to not display the text on the button. It ends up being a small square. Safari and IE7 both compensate for the lack of an equals sign.

I'm new enough that I cannot find the file that contains the markup to see if the error lies there. I've scoured the net for any similar reports but found nothing. I've generated this error on 2 different platforms (OS X, CentOS 5) using 2 different applications.

I hope this is the right place for a submission of this sort. Thanks.

Change History (1)

comment:1 Changed 8 years ago by mattmcc

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

Newforms objects don't output submit buttons, so something else outside of Django is probably generating it. Given that it's most likely not a Django bug, you can get support for the issue on the django-users mailing list or IRC channel.

Note: See TracTickets for help on using tickets.
Back to Top