Code

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6882 closed (duplicate)

Auth system should validate username on user creation.

Reported by: eddyboston Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: auth
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

According to the documentation for the Authorization system, a username must consist of "Alphanumeric characters only (letters, digits and underscores)."

This seems to be only selectively enforced. I can easily create a username with spaces in it using User.objects.create_user. Everything seems fine for most things, but once in a while a problem will occur, such as when trying to make changes to the user in the admin interface, where the no-space rule is enforced (even if the username was previously set, and we want to change another field).

My request would be to add validation checking during the user creation phase, so this error can be caught earlier.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6845. Before bringing up a major issue like this, please do search the ticket tracker.

comment:2 Changed 6 years ago by eddyboston

No need to be a snot, ubernostrum

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.