Opened 7 years ago

Closed 7 years ago

#6309 closed (duplicate)

Make Flatpages respect APPEND_SLASH=True (patch)

Reported by: Uninen Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: flatpages, APPEND_SLASH, urls
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Currently flatpages don't work very well with APPEND_SLASH=True. If user has APPEND_SLASH on and a flatpage with url="/foo/", request to url "/foo" gives an 404. See discussion at http://groups.google.com/group/django-users/browse_thread/thread/8dcddba467799670 for more information.

This patch makes flatpages respect APPEND_SLASH setting. It also adds a small notice to the flatpage docs about the change.

Attachments (1)

apped_slash_flatpages.diff (1.7 KB) - added by Uninen 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Uninen

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #6167

Note: See TracTickets for help on using tickets.
Back to Top