Code

Opened 7 years ago

Closed 6 years ago

#6167 closed (duplicate)

Flat pages do not honour APPEND_SLASH

Reported by: dkbg <dgrose@…> Owned by: nobody
Component: Contrib apps Version: master
Severity: Keywords: flatpages
Cc: semente@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Flat pages do not append a slash if they were defined as /page/ and /page is requested.

Attachments (1)

flatpages_append_slash.diff (5.6 KB) - added by SmileyChris 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by SmileyChris

comment:1 Changed 7 years ago by SmileyChris

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

Note that if you're using flat pages currently (using a pattern rather than the middleware), APPEND_SLASH is not even used because flat pages catches everything and a slash is now only appended when the non-slash path doesn't resolve.

Also added in (the start of) a test suite for flatpages!

comment:2 Changed 7 years ago by SmileyChris

See also: #6213

comment:3 Changed 6 years ago by mtredinnick

  • Triage Stage changed from Ready for checkin to Accepted

Seems to be some possibility that #6213 fixes the problem differently (better?) if I'm reading the comments there correctly. Some should sort out a unified approach here so that we're left with one patch and one ticket open (and the other one closed as a dupe or something).

comment:4 Changed 6 years ago by Guilherme M. Gondim <semente@…>

  • Cc semente@… added

comment:5 Changed 6 years ago by esaj

  • Resolution set to duplicate
  • Status changed from new to closed

I've updated the patch in #6213 to include test cases based on the ones in the patch for this ticket. Closing this ticket as a duplicate of #6213 as suggested by SmileyChris.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.