Opened 8 years ago

Closed 8 years ago

#5687 closed (fixed)

Swedish Translations patch

Reported by: Dmitri Fedortchenko <zeraien@…> Owned by: nobody
Component: Translations Version: master
Severity: Keywords: i18n translation
Cc: ludvig.ericson@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Here is a patch for swedish translations for SVN Rev 6453.

One reason for this patch is that the translation for the word "e-mail address" was in swedish translated with a colon at the end into "e-postadress:", but there are other grammatical and semantical fixes as well.

Attachments (7)

sv_translations_6453.diff (11.2 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Swedish translations patch
sv_translations_6453.2.diff (10.3 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Adjustments to the previous patch
sv_translations_6453.3.diff (10.3 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
New translation patch with a few more fixes
sv_translations_6453.4.diff (9.5 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Getting closer.…
sv_translations_6453.4.2.diff (9.8 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Getting closer, again
sv_translations_6453.4.3.diff (10.2 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Added my name as last translator ;)
sv_translations_6453.4.4.diff (10.2 KB) - added by Dmitri Fedortchenko <zeraien@…> 8 years ago.
Set the correct revision date.…

Download all attachments as: .zip

Change History (17)

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Swedish translations patch

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Adjustments to the previous patch

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

New translation patch with a few more fixes

comment:1 Changed 8 years ago by mtredinnick

  • Cc ludvig.ericson@… added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Do we have consensus on this now, Ludvig? The latest patch seems to be a couple of days before the end of the thread on django-i18n, so I'm not sure if it incorporates all the changes that were agreed or if discussion is still ongoing in a Swedish group somewhere.

comment:2 Changed 8 years ago by Ludvig Ericson <ludvig.ericson@…>

While I'm not entirely sure, it looks like it.

I'll see with django-se.

comment:3 Changed 8 years ago by Ludvig Ericson <ludvig.ericson@…>

  • Patch needs improvement set

We need a new patch. There are issues.

comment:4 Changed 8 years ago by Ludvig Ericson <ludvig.ericson@…>

(Where's edit?)

See the Google Group for why (in Swedish).

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Getting closer....

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Getting closer, again

comment:5 Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

just one issue remains, the translation for zip code. I have posted to the mailing list asking translators from other languages how they handle it.
I still feel that the swedish word describing the swedish equivalent of a "zipcode" is the proper translation for zip code, rather then "localizing" the english word.

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Added my name as last translator ;)

Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Set the correct revision date....

comment:6 Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

  • Patch needs improvement unset

Since Ludvig and Philip have vanished (nothing wrong with that, I am sure they have lives like the rest of us) I feel that I should point out that the current patch contains fixes to all the issues that were raised by them in the Swedish mailing list, except the zip code issue.

As I mentioned before the problem is that Ludvig and Philip do not agree to my translation of zip code into the Swedish equivalent "postnummer", which essentially means "postal number" and is a 5 digit number used to divide the country into areas for faster and more secure delivery of mail. Sounds familiar?

I have asked about 10 Swedish people if they thought that postnummer is a good translation for zip code and they have all said yes. However don't take my word for it, look at this thread:
http://groups.google.com/group/Django-I18N/browse_thread/thread/c89075d5728f1749/#

At least 3 django translators agree with my interpretation. Thus I feel that since all other issues that were raised in the Swedish mailing list have been ironed out, this patch is ready for commit.

comment:7 Changed 8 years ago by toxik

(I am Ludvig Ericson.)

Go ahead then, can't say I've been notified that you've made a patch that you want to push.

comment:8 Changed 8 years ago by Dmitri Fedortchenko <zeraien@…>

Are you not the same Ludvig Ericson with whom I've been talking in google groups (along with Philip)? :-)

comment:9 Changed 8 years ago by toxik

I am, but what I mean is that I didn't get you wanted to make the patch ready now, but I'd say it's fine so +1 on commit.

comment:10 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [6663]) Fixed #5687 -- Updated Swedish translation. A bit of a group effort from Dmitri
Fedortchenko, Ludvig Ericson and the django-se team.

Note: See TracTickets for help on using tickets.
Back to Top