Code

Opened 9 years ago

Closed 9 years ago

#432 closed defect (invalid)

Trac throwing errors when attempting to replace attachment

Reported by: pb@… Owned by: jacob
Component: *.djangoproject.com Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Below is the traceback I got just now (while submitting a correction to #429). I had checked the "Replace existing attachment of the same name" box. No problems when I resubmitted after unchecking the box.

Oops...
Trac detected an internal error:

'module' object has no attribute 'TICKET_ADMIN'

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/modpython_frontend.py", line 205, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.3/site-packages/trac/attachment.py", line 265, in process_request
    self._do_save(req, attachment)
  File "/usr/lib/python2.3/site-packages/trac/attachment.py", line 327, in _do_save
    perm_map = {'ticket': perm.TICKET_ADMIN,
AttributeError: 'module' object has no attribute 'TICKET_ADMIN'

Attachments (0)

Change History (1)

comment:1 Changed 9 years ago by adrian

  • Resolution set to invalid
  • Status changed from new to closed

Looks like a Trac problem -- please report it at http://projects.edgewall.com/trac/ .

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.