Opened 10 years ago

Closed 10 years ago

#433 closed enhancement (duplicate)

Add ability to delete multiple objects in a single call

Reported by: samuel Owned by: adrian
Component: Metasystem Version:
Severity: normal Keywords:
Cc: maurycypw@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

There is a way to retrieve multiple objects using get_list function. There should be also a way to delete multiple objects on a single call. For example

polls.delete(total_votes__lt=10)

Change History (5)

comment:1 Changed 10 years ago by adrian

  • Summary changed from Ability to delete multiple objects on a single call to Add ability to delete multiple objects in a single call

comment:2 Changed 10 years ago by anonymous

  • Cc maurycypw@… added

comment:3 Changed 10 years ago by rmunn@…

On ticket #436. someone suggested delete_list() as a name; I find that clearer than delete(). Otherwise, I'm +1 on this idea.

comment:4 Changed 10 years ago by adrian

  • Component changed from Database wrapper to Metasystem

comment:5 Changed 10 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #436.

Note: See TracTickets for help on using tickets.
Back to Top