Code

Opened 7 years ago

Closed 7 years ago

#3786 closed (fixed)

Misc small documentation fixes/suggestions

Reported by: Ramiro Morales Owned by: jacob
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Just some notes for stuff in django/trunk/docs IMHO not worth having separate tickets:

  1. django-admin.txt, line 360 while describing the "sqlcustom" command it still talks about "sqlinitialdata".
  1. New databases.txt file:
  • The "MySQLdb" section still has "If you are trying to use an older version of MySQL, then 1.2.0 *may* work for you."
  • Also, this file and distributions.txt aren't linked from the main documentation contents nor any other ReST documentation file yet. I don't know if this is on purpose (in that case sorry for the noise) or an overlook.

Attachments (2)

sqlinitialdata.diff (936 bytes) - added by Ramiro Morales 7 years ago.
sqlinitialdata2.diff (2.2 KB) - added by Ramiro Morales 7 years ago.
New diff with of another s/sqlinitialdata/sqlcustom/ replacement, this time in model-api.txt

Download all attachments as: .zip

Change History (18)

comment:1 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 7 years ago by Gary Wilson <gary.wilson@…>

As mentioned in #3802, which was marked a duplicate of this, sqlinitialdata is also mentiened in the model-api docs (http://www.djangoproject.com/documentation/model-api).

comment:3 Changed 7 years ago by adrian

(In [4818]) Fixed typo in docs/django-admin.txt. Refs #3786

comment:4 follow-up: Changed 7 years ago by Ramiro Morales

I see now

  1. In #3802 another occurence of "sqlinitaldata" in docs/diango.admin.txt was reported, and grepping shows another in tutorial01.txt. Find attached a mini-patch fixing this
  2. databases.txt is linked from release_notes_0.96.txt so I guess it isn't an orphan document
  3. distributions.txt is linked from install.txt so I guess it isn't an orphan document

Sorry for the noise, next time will report as separate tickets and will include patches right from the start.

Changed 7 years ago by Ramiro Morales

comment:5 Changed 7 years ago by Ramiro Morales

The Trac diff parser sees only the hunk in tutorial01.txt file, see/download the file by using the 'original format' link to get to the hunk in django.admin.txt

Changed 7 years ago by Ramiro Morales

New diff with of another s/sqlinitialdata/sqlcustom/ replacement, this time in model-api.txt

comment:6 Changed 7 years ago by Ramiro Morales

#4016 and #4017 were duplicates of this

comment:7 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Has patch set
  • Triage Stage changed from Accepted to Ready for checkin

Looks ready to go. I'm not seeing the issue with OP's request 2a, and I'll let one of the core devs decide about 2b.

comment:8 follow-up: Changed 7 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [5004]) Fixed #3786 -- Fixed sqlinitialdata references in some docs. Thanks, Ramiro Morales

comment:9 in reply to: ↑ 8 ; follow-up: Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Has patch unset
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Triage Stage changed from Ready for checkin to Design decision needed

Replying to adrian:

(In [5004]) Fixed #3786 -- Fixed sqlinitialdata references in some docs. Thanks, Ramiro Morales

So is that a no for 2b?

comment:10 in reply to: ↑ 9 Changed 7 years ago by Ramiro Morales

Replying to Gary Wilson <gary.wilson@gmail.com>:

So is that a no for 2b?

Gary, see comment 4 (http://code.djangoproject.com/ticket/3786#comment:4)

comment:11 in reply to: ↑ 4 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Triage Stage changed from Design decision needed to Ready for checkin

Thanks Ramiro...

Replying to Ramiro Morales:

  1. databases.txt is linked from release_notes_0.96.txt so I guess it isn't an orphan document

I would say this should be linked to from install.txt in the "Get your database running" section also since the 0.96 release notes won't be current forever.

comment:12 Changed 7 years ago by russellm

(In [5009]) Refs #3786 -- Added reference to database-specific documentation in install.txt.

comment:13 follow-up: Changed 7 years ago by mtredinnick

  • Triage Stage changed from Ready for checkin to Accepted

It's difficult to work out from all the above comments what remains to be done to close this ticket. It's certainly not "ready for checkin", since it's not clear there's anything needing checking in.

Can somebody who's familiar with the history give a succient summary of what remains to be done and/or decided, please?

comment:14 in reply to: ↑ 13 Changed 7 years ago by Ramiro Morales < >

Replying to mtredinnick:

Can somebody who's familiar with the history give a succient summary of what remains to be done and/or decided, please?

Malcolm, sorry because I'm the responsible of the messy state of this ticket. This is the summary you asked for:

ReportStatusNotes
Replacement of "sqlinitialdata" occurences with "sqlcustom"DONE by adrian in [4818] and [5009]-
Enhance visibility of the databases.txt fileDONE by Russell in [5009]-
Enhance visibility of the distributions.txt file-Later I realized it's linked from install.txt so this report could be flagged as bogus if core devs consider it is visible enough
The databases.txt contains "If you are trying to use an older version of MySQL, then 1.2.0 *may* work for you."-I opened the ticket without knowing the mysql_old backend had been re-added three days before so this report may be flagged as bogus

comment:15 Changed 7 years ago by mtredinnick

(In [5044]) Added a note that MySQLdb versions prior to 1.2.1p2 will only work with
mysql_old backend. Refs #3786.

comment:16 Changed 7 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from reopened to closed

Thanks for the summary Ramiro. I've updated the databases.txt file a little to indicate when MySQLdb 1.2.0 may or definitely isn't appropriate. I think having distributions.txt linked from install.txt is sufficient, since it's definitely mentioned in the right place there (as step 1 of the installation process for Django).

I think we can call this closed now. Thanks for paying attention to the little details like this; it's definitely improved things.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.