Opened 3 months ago

Closed 3 months ago

#34982 closed Bug (fixed)

Visual regression for helptext at certain screen sizes

Reported by: Mariusz Felisiak Owned by: Tom Carrick
Component: contrib.admin Version: 4.2
Severity: Release blocker Keywords:
Cc: Tom Carrick Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: yes

Description (last modified by Mariusz Felisiak)

Django 4.1 on small screens (< 1024 px)




Django 4.2 on small screens (< 1024 px)



LANGUAGE_CODE = "ar-DZ"

Regression in 96a598356a9ea8c2c05b22cadc12e256a3b295fd.

Attachments (4)

before1.png (40.4 KB ) - added by Mariusz Felisiak 3 months ago.
before2.png (23.4 KB ) - added by Mariusz Felisiak 3 months ago.
after1.png (41.4 KB ) - added by Mariusz Felisiak 3 months ago.
after2.png (24.4 KB ) - added by Mariusz Felisiak 3 months ago.

Download all attachments as: .zip

Change History (17)

by Mariusz Felisiak, 3 months ago

Attachment: before1.png added

by Mariusz Felisiak, 3 months ago

Attachment: before2.png added

by Mariusz Felisiak, 3 months ago

Attachment: after1.png added

by Mariusz Felisiak, 3 months ago

Attachment: after2.png added

comment:1 by Mariusz Felisiak, 3 months ago

Description: modified (diff)

comment:2 by Mariusz Felisiak, 3 months ago

UI/UX: set

comment:3 by Mariusz Felisiak, 3 months ago

Owner: changed from nobody to Tom Carrick
Status: newassigned

comment:4 by Mariusz Felisiak, 3 months ago

Description: modified (diff)

comment:5 by Tom Carrick, 3 months ago

Summary: Visual regression for helptext with RTL languages.Visual regression for helptext at certain screen sizes

I reworded the summary as it doesn't only affect RTL. I still don't see a reasonable way to fix it, and since we're making some effort to have admin fields be stacked rather than inline it might not be worth going to a lot of effort to fix if it's not simple.

comment:6 by Tom Carrick, 3 months ago

Has patch: set

comment:7 by Natalia Bidart, 3 months ago

Triage Stage: UnreviewedAccepted

comment:8 by Natalia Bidart, 3 months ago

Triage Stage: AcceptedReady for checkin

comment:9 by Natalia <124304+nessita@…>, 3 months ago

Resolution: fixed
Status: assignedclosed

In 729266c6:

Fixed #34982 -- Fixed admin's read-only password widget and help texts alignment for tablet screen size.

Co-authored-by: Sarah Boyce <42296566+sarahboyce@…>

comment:10 by Natalia <124304+nessita@…>, 3 months ago

In 432bfa26:

[5.0.x] Fixed #34982 -- Fixed admin's read-only password widget and help texts alignment for tablet screen size.

Co-authored-by: Sarah Boyce <42296566+sarahboyce@…>

Backport of 729266c6f29c7a0677b24926a86a767ef3078b26 from main

comment:11 by Natalia <124304+nessita@…>, 3 months ago

In bd0ea8c:

[4.2.x] Fixed #34982 -- Fixed admin's read-only password widget and help texts alignment for tablet screen size.

Co-authored-by: Sarah Boyce <42296566+sarahboyce@…>

Backport of 729266c6f29c7a0677b24926a86a767ef3078b26 from main

comment:12 by Mariusz Felisiak, 3 months ago

Resolution: fixed
Status: closednew
Triage Stage: Ready for checkinAccepted

Reopening as RTL issue is not solved (check out #35003).

in reply to:  12 comment:13 by Mariusz Felisiak, 3 months ago

Resolution: fixed
Status: newclosed
Triage Stage: AcceptedReady for checkin

Replying to Mariusz Felisiak:

Reopening as RTL issue is not solved (check out #35003).

Decided to close again, as #35003 is related but it's not a regression.

Note: See TracTickets for help on using tickets.
Back to Top