Opened 5 months ago

Closed 5 months ago

#34834 closed Cleanup/optimization (fixed)

Use `search` role for the admin changelist search form

Reported by: Thibaud Colas Owned by: Lemuel Sta Ana
Component: contrib.admin Version: 4.2
Severity: Normal Keywords: accessibility, screen reader, landmarks
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

Related: #34832, #34833. Django’s ChangeListSearchForm and its search_form.html currently use <div id="toolbar"><form id="changelist-search" method="get"></form></div> markup for the form. It would be nice for screen reader users to use a role="search" on the form, so it’s explicitly identified as a search form when navigating the page by region.

In the future it would be even better to convert the wrapping toolbar div to use the search HTML element, but browser support isn’t there yet.

Change History (8)

comment:1 by faizan2700, 5 months ago

Please assign me this ticket. I understand what needs to be done.
My Introduction:
I have graduated from IIIT Pune in 2021. I am doing freelancing since college only, I have worked in ServiceNow and CleverTaps before currently I am working on my startup.

comment:2 by Mariusz Felisiak, 5 months ago

Easy pickings: set
Triage Stage: UnreviewedAccepted

faizan2700, you can assign yourself a ticket.

comment:3 by Lemuel Sta Ana, 5 months ago

Owner: changed from nobody to Lemuel Sta Ana
Status: newassigned

Claiming ticket.

comment:4 by Lemuel Sta Ana, 5 months ago

Has patch: set
Last edited 5 months ago by Lemuel Sta Ana (previous) (diff)

comment:5 by Mariusz Felisiak, 5 months ago

Needs tests: set

comment:6 by Lemuel Sta Ana, 5 months ago

Regression test added as per commit

comment:7 by Mariusz Felisiak, 5 months ago

Needs tests: unset
Triage Stage: AcceptedReady for checkin

comment:8 by Mariusz Felisiak <felisiak.mariusz@…>, 5 months ago

Resolution: fixed
Status: assignedclosed

In 969ecb82:

Fixed #34834 -- Added role="search" to the admin changelist search form.

Note: See TracTickets for help on using tickets.
Back to Top