#30586 closed Bug (duplicate)

Django 2.2 compatibility with PyMySQL.

Reported by: Suthat Ronglong Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Normal Keywords: PyMySQL
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Regarding unexpected return result on using PyMySQL with Django 2.2.x:

Django 2.1.x used to cast every query into "str" like below
https://github.com/django/django/blob/stable/2.1.x/django/db/backends/mysql/operations.py#L134

Django 2.2.x they changed the code by using query.decode instead of force_text method.
https://github.com/django/django/blob/stable/2.2.x/django/db/backends/mysql/operations.py#L140

Reference as a proposed solution is discussed right here: https://github.com/PyMySQL/PyMySQL/issues/790#issuecomment-484201388

Thanks.

Change History (1)

comment:1 Changed 18 months ago by Mariusz Felisiak

Has patch: unset
Resolution: duplicate
Status: newclosed
Summary: Django 2.2 Compatibility with PyMySQLDjango 2.2 compatibility with PyMySQL.
Version: 2.2master

Duplicate of #30380 (it doesn't qualify for a backport).

Note: See TracTickets for help on using tickets.
Back to Top