Opened 2 years ago

Closed 2 years ago

#20906 closed Bug (fixed)

Test failure on Oracle: test_lookup_with_non_string_value

Reported by: shai Owned by: nobody
Component: Database layer (models, ORM) Version: 1.4
Severity: Normal Keywords: oracle
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Running tests on updated stable/1.4.x:

FAIL: test_lookup_with_non_string_value (regressiontests.admin_filters.tests.ListFiltersTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/django/django/tests/regressiontests/admin_filters/tests.py", line 685, in test_lookup_with_non_string_value
    self.assertEqual(choices[2]['display'], u'DEV')
AssertionError: u'DSN' != u'DEV'
- DSN
+ DEV

Change History (3)

comment:1 Changed 2 years ago by timo

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

I can't reproduce this on my Oracle setup -- it looks like it may be dependent on Python version (set ordering). It may be fixed if we backport [1ae64e96] (looks like 1.5 doesn't have the fix either though). Could you confirm?

comment:2 Changed 2 years ago by timo

Actually I can reproduce if I run the entire test suite instead of just the admin_filters app. Testing if backporting the above commit (which I now see was backported to 1.5.x) solves the issue.

comment:3 Changed 2 years ago by Tim Graham <timograham@…>

  • Resolution set to fixed
  • Status changed from new to closed

In d5da495a2edc741b6496821baa0d6bcee9dce9bb:

[1.4.x] Fixed #20906 -- Fixed a dependence on set-ordering in tests

Backport of 1ae64e96c1 from master

Note: See TracTickets for help on using tickets.
Back to Top