Code

Opened 8 years ago

Closed 8 years ago

#1987 closed enhancement (duplicate)

CharField with treating UTF-8 encoding

Reported by: hironobu@… Owned by: adrian
Component: Core (Other) Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Database: MySQL (<5.0)

"CharField" does not decode/encode UTF-8 string encoding. When CharField loads UTF-8 byte-sequence from database, directly holds it as attribute, and saves into database "as it is". There's no convertion to "Unicode" string internally.

Attachments (1)

django-utf8string.patch (2.5 KB) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by anonymous

comment:1 Changed 8 years ago by hironobu@…

This will be because of database's encoding handling, so it will depend on database's product, kind, version, ...etc.

comment:2 Changed 8 years ago by anonymous

So how do you propose to solve this problem?

comment:3 Changed 8 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #952.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.