Opened 9 years ago

Closed 8 years ago

#1986 closed defect (worksforme)

floatfield admin list not working properly

Reported by: rob@… Owned by: adrian
Component: contrib.admin Version: master
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I found a bug in "django\contrib\admin\templatetags\admin_list.py"

line 156 was:

result_repr = ('%%.%sf' % f.decimal_places) % field_val

which got me a type error, I fixed this to be:

result_repr = ('%%.%sf' % f.decimal_places) % float(field_val)

Attachments (1)

admin_list_bug.patch (652 bytes) - added by rob@… 9 years ago.
the patch :)

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by rob@…

the patch :)

comment:1 Changed 9 years ago by anonymous

  • Summary changed from floatfield admin list not working properlu to floatfield admin list not working properly

comment:2 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this error. If you are still getting this error, could you please give a bit more detail into the steps necessary to cause the error.

Note: See TracTickets for help on using tickets.
Back to Top