Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#19850 closed Bug (fixed)

admin_static templatetag is not using the staticfiles' storage backend url

Reported by: duduklein@… Owned by: Jannis Leidel
Component: contrib.admin Version: 1.5-rc-1
Severity: Release blocker Keywords: staticfiles storage backend templatetag
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The admin_static templatetag checks for statifiles app and then imports the appropriate static templatetag.

The issue is that even when staticfiles contrib app is "installed", the templatetag imported is "static" while the one that uses the storage backend is "do_static". In Django 1.4, there was no "do_static" function, only "static",

This is the commit that seems to have broken it.

Change History (5)

comment:1 Changed 4 years ago by Jannis Leidel

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Severity: NormalRelease blocker
Triage Stage: UnreviewedAccepted

comment:2 Changed 4 years ago by Jannis Leidel

comment:3 Changed 4 years ago by Jannis Leidel

Owner: changed from nobody to Jannis Leidel
Status: newassigned

comment:4 Changed 4 years ago by Jannis Leidel <jannis@…>

Resolution: fixed
Status: assignedclosed

In c12891e8cd629cc16fc5d22e485b87ca3169df2c:

Fixed #19850 -- Use configured staticfiles storage to find the URL of a static file in the admin.

comment:5 Changed 4 years ago by Jannis Leidel <jannis@…>

In f96dd05542885d9839d4c79639164551e1f01563:

[1.5.X] Fixed #19850 -- Use configured staticfiles storage to find the URL of a static file in the admin.

Note: See TracTickets for help on using tickets.
Back to Top