Opened 6 years ago

Closed 6 years ago

Last modified 3 months ago

#19587 closed New feature (duplicate)

makemessages to update PO file only if translation's changed

Reported by: Natim87 Owned by: nobody
Component: Internationalization Version: master
Severity: Normal Keywords:
Cc: Carlos Palol Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I would like to run makemessages as a pre-commit procedure but makemessages always modify the content of my PO file even if translations didn't actually changed.

-"POT-Creation-Date: 2013-01-09 09:36+0100\n"
+"POT-Creation-Date: 2013-01-10 09:41+0100\n"
...
-#: forms.py:28
+#: forms.py:32

For line numbers I can use --no-location but how can I ask to not update the Creation-Date if there is no translation changes ?

Change History (5)

comment:1 Changed 6 years ago by Claude Paroz

Triage Stage: UnreviewedAccepted
Type: UncategorizedNew feature
Version: 1.4master

comment:2 Changed 6 years ago by Ramiro Morales

Component: TranslationsInternationalization

comment:3 Changed 6 years ago by Ramiro Morales

Resolution: duplicate
Status: newclosed

Duplicate of #6106.

comment:4 Changed 9 months ago by Carlos Palol

Cc: Carlos Palol added

comment:5 Changed 3 months ago by Dalius Dobravolskas

Sorry, to reopen discussion about old problem. This is clearly not duplicate of #6106. #6106 is about the fact that makemessages updates POT-Creation-Date when there are changes and this is expected. This defect is about the fact that POT-Creation-Date is updated even if there are no changes.

I am affected by this problem and only see that others are affected as well. E.g.:
https://stackoverflow.com/questions/28114368/detecting-changes-to-django-translations-po-files-in-travisci
https://shuup.readthedocs.io/en/latest/_modules/shuup/core/management/commands/makemessages.html - here is Django based product that is monkey patching Django.

Note: See TracTickets for help on using tickets.
Back to Top