Opened 3 years ago

Closed 3 years ago

#19529 closed Bug (duplicate)

Searching documentation for "class based views" gives ten times the same result

Reported by: wim@… Owned by: nobody
Component: Documentation Version: master
Severity: Normal Keywords: documentation, search
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

When searching for "classed base views" in the django documentation development trunk, the same page is shown ten times in the list of results.

See:

https://docs.djangoproject.com/search/?q=class+based+views&release=1

Change History (7)

comment:1 Changed 3 years ago by apollo13

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Indeed, that's not exactly optimal ;)

comment:2 Changed 3 years ago by aaugustin

  • Resolution set to fixed
  • Status changed from new to closed

I've rebuilt the search indexes and the problem appears to be fixed.

comment:3 Changed 3 years ago by aaugustin

  • Resolution fixed deleted
  • Status changed from closed to new

This re-appeared after the next execution of the cron.

comment:4 Changed 3 years ago by timo

Are we using the latest version of whoosh? Apparently there is a bug in older versions, although someone claims this problem may still exist. I cannot reliably reproduce this using whoosh 2.4.1.

https://bitbucket.org/mchaput/whoosh/issue/97/search-index-contains-a-lot-of-duplicates

comment:5 Changed 3 years ago by aaugustin

As discussed on IRC, xapian is used in production, whoosh in development.

Versions are pinned in the requirements file.

comment:6 Changed 3 years ago by aaugustin

I strongly suspect #18930 is the root cause for the problem discussed here.

comment:7 Changed 3 years ago by aaugustin

  • Resolution set to duplicate
  • Status changed from new to closed

This was fixed by the fix for #18930.

Note: See TracTickets for help on using tickets.
Back to Top