Code

#19530 closed Uncategorized (worksforme)

Error in geodjango tutorial

Reported by: anonymous Owned by: nobody
Component: Documentation Version: 1.4
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

I followed all of the Geodjango Tutorial instructions precisely. But when I run syncdb, the following errors occur:

django.core.exceptions.ImproperlyConfigured: 'postgis' isn't an available database backend.
Try using django.db.backends.XXX, where XXX is one of:

'dummy', 'mysql', 'oracle', 'postgresql_psycopg2', 'sqlite3'

Error was: No module named postgis.base

Apparently, I'm not the only one encountering this problem, because there are several blog posts about this error. I'm running Mac OS X 10.6 and used Homebrew to install geodjango dependencies. Linux users are reporting the same error.

Attachments (0)

Change History (1)

comment:1 Changed 16 months ago by claudep

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to worksforme
  • Status changed from new to closed

If you think there is an error in the tutorial, please tell us what the error is. If you don't know what the problem is, then use support channels instead.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.