Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18228 closed New feature (duplicate)

Add get_git_revsion() to django.utils.version and refactor django.get_version()

Reported by: pressureman Owned by: nobody
Component: Core (Other) Version: master
Severity: Normal Keywords: git
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no


Attached patch adds function to determine the git HEAD revision hash, and modifies django.get_version() accordingly.

Attachments (1)

get_git_version.diff (2.0 KB) - added by pressureman 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by pressureman

comment:1 Changed 4 years ago by aaugustin

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks, but this is a duplicate of #18224.

To avoid duplicating efforts, it's best to check existing tickets before writing patches, for instance with the "Search" field at the top right of each page.

comment:2 Changed 4 years ago by pressureman

Sorry. Didn't expect that functionality to be in there so quickly. I wrote my patch last night, before #18224 was even open.

Note: See TracTickets for help on using tickets.
Back to Top