Opened 3 years ago

Closed 3 years ago

#17347 closed Bug (fixed)

regressiontests.servers.tests.AdminMediaHandlerTests.test_media_urls fails on Windows

Reported by: shelldweller Owned by: ramiro
Component: contrib.admin Version: master
Severity: Release blocker Keywords: regressiontests
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description (last modified by ramiro)

======================================================================
FAIL: test_media_urls (regressiontests.servers.tests.AdminMediaHandlerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\work\src\django-svn\trunk\tests\regressiontests\servers\tests.py", line 63, in test_media_urls
    "Got: %s, Expected: %s, URL was: %s" % (output, desired, url))
AssertionError: Got: D:\work\src\django-svn\trunk\django\contrib\admin\static\admin\css\base.css, Expected: d:\work\src\
django-svn\trunk\django\contrib\admin\static\admin\css\base.css, URL was: /static/admin/css/base.css

Both output and desired need to be normcase'd. Patch attached.

Attachments (1)

test_media_urls.diff (1.2 KB) - added by shelldweller 3 years ago.

Download all attachments as: .zip

Change History (4)

Changed 3 years ago by shelldweller

comment:1 Changed 3 years ago by ramiro

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to ramiro
  • Patch needs improvement unset
  • Status changed from new to assigned

Thanks.

(Please use the Preview Trac functionality before submitting a ticket or a comment to avoid obvious formatting errors.)

comment:2 Changed 3 years ago by ramiro

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 3 years ago by aaugustin

  • Component changed from Testing framework to contrib.admin
  • Resolution set to fixed
  • Severity changed from Normal to Release blocker
  • Status changed from assigned to closed

This is a duplicate of #16203 and it was fixed at r17280.

Note: See TracTickets for help on using tickets.
Back to Top