Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17346 closed Uncategorized (invalid)


Reported by: anonymous Owned by: nobody
Component: Uncategorized Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description (last modified by kmtracey)

I have my django application on a apache server with mod_wsgi When i start it with python runserver, it works perfectly, but if I try to use it over apache/mod_wsgi it causes major Error (MemoryError at /index) Any ideas?

Description of problem:

MemoryError at /index

No exception supplied

Request Method: 	GET
Request URL:
Django Version: 	1.3.1
Exception Type: 	MemoryError
Exception Location: 	/usr/lib/python2.7/ctypes/ in <module>, line 552
Python Executable: 	/usr/bin/python
Python Version: 	2.7.1
Python Path: 	


tail -75 error_log:

[Mon Dec 05 10:00:55 2011] [notice] caught SIGTERM, shutting down
[Mon Dec 05 10:01:02 2011] [notice] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Mon Dec 05 10:01:02 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Dec 05 10:01:02 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 05 10:01:02 2011] [notice] Digest: done
[Mon Dec 05 10:01:02 2011] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Mon Dec 05 10:01:02 2011] [notice] mod_python: using mutex_directory /tmp 
[Mon Dec 05 10:01:02 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_python/3.3.1 Python/2.7.1 mod_wsgi/3.2 configured -- resuming normal operations


Change History (4)

comment:1 Changed 4 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to invalid
  • Status changed from new to closed

comment:2 Changed 4 years ago by anonymous

Was this issue ever resolved. I have exactly the same problem. The site works when I use runserver but it throws the Mmeroy Error when I use Apache

comment:3 Changed 4 years ago by kmtracey

  • Description modified (diff)

comment:4 Changed 4 years ago by kmtracey

Anonymous: There's not enough information in the original description to even speculate as to whether there is a bug in Django causing it. The number of people able to successfully run Django under Apache rather argues that the problem is specific to the project/configuration; therefore until there is something that points to a bug in Django please use other support channels (see for example Trac isn't meant for debugging user's projects/configurations.

Note: See TracTickets for help on using tickets.
Back to Top