Opened 4 years ago

Closed 4 years ago

#15837 closed Cleanup/optimization (fixed)

Consolidate localflavor tests

Reported by: julien Owned by: julien
Component: contrib.localflavor Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: yes UI/UX: no

Description

Localflavor tests are spread out between two locations: source:django/trunk/tests/regressiontests/forms/localflavor and source:django/trunk/tests/regressiontests/localflavor

For clarity's sake, the tests in the former location should be moved to the latter one.

Change History (5)

comment:1 Changed 4 years ago by aaugustin

  • Easy pickings set
  • Triage Stage changed from Unreviewed to Accepted
  • Version changed from 1.2 to 1.3

comment:2 Changed 4 years ago by rodriguealcazar

  • Owner changed from nobody to rodriguealcazar
  • Status changed from new to assigned

comment:3 Changed 4 years ago by julien

  • UI/UX unset

Also, in the process of consolidating the tests, it would be nice to avoid having to repeat imports as currently in source:django/trunk/tests/regressiontests/forms/localflavortests.py and source:django/trunk/tests/regressiontests/forms/tests/__init__.py. That particular cleanup issue was raised in #16365, closed as dupe in favour of this one.

comment:4 Changed 4 years ago by julien

  • Owner changed from rodriguealcazar to julien
  • Status changed from assigned to new

No update in 3 months. I'll take a look at it. Let me know if you've got any WIP.

comment:5 Changed 4 years ago by julien

  • Resolution set to fixed
  • Status changed from new to closed

In [16680]:

Fixed #15837. Consolidated all the locaflavor tests into a single, logical, place (regressiontests/localflavor/).

Note: See TracTickets for help on using tickets.
Back to Top