Code

Opened 3 years ago

Closed 3 years ago

#16365 closed Cleanup/optimization (duplicate)

Simplify imports in localflavor tests

Reported by: julien Owned by: nobody
Component: Testing framework Version: 1.3
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

The locaflavor tests could do with a little cleanup, in particular to avoid having to repeat imports in source:django/trunk/tests/regressiontests/forms/localflavortests.py and source:django/trunk/tests/regressiontests/forms/tests/__init__.py. See a suggestion for a better structure in the attached patch.

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by jezdez

Don't see a patch attached.

comment:2 Changed 3 years ago by julien

Sorry I was pushing the patch to github as it was too big for Trac: https://github.com/jphalip/django/commit/13e0eaa39f9b3ec313934aecdde3201fee5f4ec8

Checking this in would likely break all the other pending patches to localflavor, although the fix would be easy (tests are just moved to a different directory). A lot of different people contribute to localflavor, and so I think it is worth making things as clean and tidy as possible.

comment:3 Changed 3 years ago by jezdez

I wouldn't mind having the test consolidated, in fact I think this ticket is a duplicate of #15837. What do you think?

comment:4 Changed 3 years ago by julien

  • Resolution set to duplicate
  • Status changed from new to closed

Hmm.... I originally thought that these would be two different issues but now that you're pointing it out, I think that yes, this particular cleanup could be done as part of #15837. I'll close this one as dupe and will leave a specific comment in the other one. Thanks for the tip!

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.