django core and contrib named urls should follow a convention
|Reported by:||tvon||Owned by:||nobody|
|Has patch:||no||Needs documentation:||no|
|Needs tests:||no||Patch needs improvement:||no|
There are a few named urls in django that don't seem to follow any particular naming convention, it might be good to come up with one and stick to it.
What I've noticed:
django.contrib.admindocs has django-admindocs-docroot (django-app-action)
django.contrib.comments uses comments-post-comment (app-action)
django.contrib.admin: uses a mix of admin:APP_MODEL_ACTION for the generated bits, and names such as password_change or logout elsewhere (just 'action')
Maybe I'm being overly anal about it, but it seems like there should be some kind of pattern here. I'm not sure what convention would make sense since you wouldn't want to tie the url name to a view or package, necessarily, but it at least seems like the urls should be somehow namespaced.
I'd file this under 'trivial' if I could...