Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14360 closed (duplicate)

Clarify documentation of triage states

Reported by: russellm Owned by: nobody
Component: Documentation Version: 1.2
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

via Waylan Limberg, on django-developers:

So, in other words, accepted simply means that the ticket reports a
valid bug or feature request that is considered worth fixing, but
offers to indication as to the status of any patches for committing.
Obviously, some seem to imply the later meaning into "Accepted" which
could raise the question regarding whether it is named correctly (I
say it is fine). But, more importantly, is there a place were each
status is simply defined?

Sure there is this:
http://docs.djangoproject.com/en/dev/internals/contributing/#ticket-triage

But that hardly makes clear exactly what "accepted" actually means.
The text in that section is helpful to understanding the basic
process, but if someone changes the status of my ticket, there's no
definitive place to go and see exactly what that status means.

In fact, in reading the list over the last few years, I have the
impression that this is a problem that is repeated constantly. People
don't understand what the various statuses mean and get frustrated
when things do not happen as they expected. I think perhaps clearer
documentation would help in this case.

Change History (4)

comment:1 Changed 4 years ago by russellm

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 4 years ago by gsakkis

Obviously, some seem to imply the later meaning into "Accepted" which could raise the question regarding whether it is named correctly (I say it is fine)

I disagree. Especially for a ticket with a patch, I read "Accepted" as "the patch has been reviewed and accepted by the powers that be (albeit not applied yet for whatever reason)". What's adding to the confusion is the (as it turns out unrelated) "accept ticket" radio button action, as I had the chance to find out very recently :)

I propose "Verified" or "Confirmed" as much less ambiguous alternatives of "Accepted".

Sure there is this: http://docs.djangoproject.com/en/dev/internals/contributing/#ticket-triage

But that hardly makes clear exactly what "accepted" actually means.

I have to disagree again, sorry :) To me this link actually does explain what "Accepted" means for Django. The problem is, of course, that it's probably the first time I see it (or maybe I had seen time once upon a time and completely forgot about it). If the term "Accepted" remains as is, a link to this picture just besides (or on top of) the triage stage widget might help alleviate the problem. I still prefer the rename to "Verified" or "Confirmed".

Just my 0.02€

comment:3 Changed 4 years ago by gabrielhurley

  • Resolution set to duplicate
  • Status changed from new to closed

This will be fixed in #14401, for which I am actively developing a patch. As such I'm going to close this one as a duplicate.

In the meantime, please review and contribute to the draft text in http://code.djangoproject.com/wiki/ContributingHowTo.

comment:4 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top