Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14358 closed (duplicate)

History changes in admin don't show verbose_name

Reported by: mordicuac Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: history, verbose_name, admin, sprintdec2010
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the admin, while viewing the changes of any item, they show the field name, not the verbose name

Attachments (2)

14358_history_verbose_field_name.py (612 bytes) - added by julien 4 years ago.
14358_history_verbose_field_name.diff (612 bytes) - added by julien 4 years ago.
Patch in diff format this time

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by dariog

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I can reproduce it.
Why do you think is a bug?

comment:2 Changed 4 years ago by julien

  • Has patch set
  • Keywords sprintdec2010 added
  • milestone set to 1.3
  • Triage Stage changed from Unreviewed to Accepted

Confirming the bug. Patch coming.

Changed 4 years ago by julien

Changed 4 years ago by julien

Patch in diff format this time

comment:3 Changed 4 years ago by cogat

  • Triage Stage changed from Accepted to Design decision needed

I think this counts as a problem for end-users seeing the changelist, who would understand verbose names better. OTOH, for debug purposes, it would be more useful to have the field names, as they are necessarily unique, untranslated, etc.

Perhaps both is best?

comment:4 Changed 4 years ago by ramiro

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12952.

comment:5 Changed 3 years ago by jacob

  • milestone 1.3 deleted

Milestone 1.3 deleted

Note: See TracTickets for help on using tickets.
Back to Top