Opened 7 years ago

Closed 7 years ago

#11923 closed (duplicate)

Suspected typo in django/db/models/sql/

Reported by: Greg Wogan-Browne Owned by: nobody
Component: Database layer (models, ORM) Version: 1.1
Severity: Keywords:
Cc: django@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I believe I have found a typo in [source:/django/tags/releases/1.1/django/db/models/sql/ django/db/models/sql/] at line 1400.

This line causes a TypeError ("update() takes exactly one argument (2 given)"). Looking at it, and the surrounding code (specifically line 1417) I believe the intent is instead of:

avoid.update(self.dupe_avoidance.get(id(opts), lhs_col),())

it should actually be:

avoid.update(self.dupe_avoidance.get((id(opts), lhs_col),()))

Attachments (1)

django-ticket-11923.patch (812 bytes) - added by Greg Wogan-Browne 7 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 7 years ago by Greg Wogan-Browne

Cc: django@… added
Has patch: set
Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset

Changed 7 years ago by Greg Wogan-Browne

Attachment: django-ticket-11923.patch added

comment:2 Changed 7 years ago by Alex Gaynor

Resolution: duplicate
Status: newclosed

Duplicate of #11764.

Note: See TracTickets for help on using tickets.
Back to Top