Opened 6 years ago

Closed 6 years ago

#11924 closed (duplicate)

Email headers always use the default encoding

Reported by: IanLewis Owned by: nobody
Component: Core (Mail) Version: 1.1
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When sending an email, the EmailMessage uses either the messages encoding property or if that isn't available it uses the DEFAULT_ENCODING setting. This behavior should apply to email headers as well. Currently even if a EmailMessage object's encoding property is set the DEFAULT_ENCODING is used to encode email headers.

This means that you cannot send emails with headers encoded in any encoding other than the DEFAULT_ENCODING which is required for some mobile devices (particularly Japanese mobiles) and email readers.

Change History (4)

comment:1 Changed 6 years ago by thejaswi_puthraya

  • Component changed from Uncategorized to django.core.mail
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by russellm

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 6 years ago by russellm

I suspect #11934 is an example of how this can be a problem.

comment:4 Changed 6 years ago by russellm

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6918

Note: See TracTickets for help on using tickets.
Back to Top