Opened 6 years ago

Closed 5 years ago

#11554 closed (fixed)

Several errors in Generic Views Documentation

Reported by: bunajim Owned by: ramiro
Component: Documentation Version: master
Severity: Keywords: Generic Views
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description


Hi there,
While reading the Generic views Section I noticed a typo (I think) in several places. It starts from the section Generic views of objects.
The docs refer to lists of books when it should be publishers and lists of publishers when it should be books.
Example
"To build a list page of all books, we'd use a URLconf along these lines:" <<< should have been "list page of all publishers".
After that it continues
"This template will be rendered against a context containing a variable called object_list that contains all the book objects. A very simple template might look like the following:"
Notice how it should have been "publisher objects" instead of "book objects" according to the urlconf code above it.
This appears in a few other places after this one too.

Other than that I want to thank you for an excellent source of documentation. I'm new to python and django and I can already build simple apps after 2 days worth of reading. Thank you very much for your efforts.

Best regards,
Abdullah Alsalal

Attachments (1)

11554.diff (3.1 KB) - added by ramiro 6 years ago.
Patch for this ticket, applies cleanly to thr 1.0.x branch too.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to ramiro
  • Patch needs improvement unset
  • Status changed from new to assigned

Good catch!

This is actually a more general solution to something #11335 (r11028, r11029) hinted at. I didn't review the content when copying from the book chapter (r11025, r11026 and r11027)

Changed 6 years ago by ramiro

Patch for this ticket, applies cleanly to thr 1.0.x branch too.

comment:2 Changed 6 years ago by ramiro

  • Has patch set

comment:3 Changed 6 years ago by Alex

  • Triage Stage changed from Unreviewed to Accepted

comment:4 Changed 6 years ago by ramiro

  • Summary changed from Several typos in Generic Views Documentation to Several errors in Generic Views Documentation

comment:5 Changed 6 years ago by timo

  • Triage Stage changed from Accepted to Ready for checkin

comment:6 Changed 5 years ago by lukeplant

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [11499]) Fixed #11554: Several errors in Generic Views Documentation.

Thanks Ramiro.
Refs #11477 - that ticket should have been marked a duplicate of #11554

Note: See TracTickets for help on using tickets.
Back to Top