Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#11477 closed (fixed)

Generic views doc points out design flaw with wrong queryset

Reported by: msmith64 Owned by: nobody
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

http://docs.djangoproject.com/en/dev/topics/generic-views/#adding-extra-context points out a "subtle bug"; however, the description refers to "Publisher.objects.all()". The following Note section explicitly states that, "This problem doesn't apply to the queryset generic view argument," which means that the previous paragraph must refer to "Books.objects.all()", not "Publisher.objects.all()".

Attachments (1)

11477.diff (948 bytes) - added by SmileyChris 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by SmileyChris

comment:1 Changed 6 years ago by SmileyChris

  • Component changed from Uncategorized to Documentation
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin
  • Version changed from 1.0 to SVN

comment:2 Changed 5 years ago by lukeplant

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r11484, thanks.

comment:3 Changed 5 years ago by lukeplant

(In [11499]) Fixed #11554: Several errors in Generic Views Documentation.

Thanks Ramiro.
Refs #11477 - that ticket should have been marked a duplicate of #11554

Note: See TracTickets for help on using tickets.
Back to Top