Code

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#1120 closed defect (duplicate)

Development server ignores changing the TIME_ZONE information

Reported by: Marek Kubica Owned by: adrian
Component: django-admin.py runserver Version:
Severity: minor Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

While I was trying different time zones in settings.py (edit the file, save it, see the development server reloading) I noticed that the change of TIME_ZONE does not affect the server. You have to stop the server completely and restart it to let it see the change.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by anonymous

Now, even after I restart the server completely, the TIME_ZONE still does not affect the server. Indeed, it seems that the TIME_ZONE setting has no effect at all.

comment:2 Changed 8 years ago by adrian

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen with more information, such as your OS, database engine and Django version, if this is still an issue.

comment:3 Changed 8 years ago by scott.benjamin@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This happens to me on Windows XP, Python 2.4.3, with Django from trunk as of June 9 14:00 GMT using the SQLite db engine.

I am in New Zealand GMT +12 and no matter what timezone I set the TIME_ZONE setting to it only displays GMT in the output from the servers as well as the templates using {% now %}

comment:4 Changed 8 years ago by mtredinnick

The other important question here is what is the value of your TIME_ZONE string in settings.py? I'm wondering how much this is related to #1977.

comment:5 Changed 8 years ago by adrian

  • Component changed from django-admin.py to django-admin.py runserver

comment:6 Changed 7 years ago by SmileyChris

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #2315

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.