Code

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1119 closed defect (duplicate)

Time zone configuration does not work properly

Reported by: Marek Kubica Owned by: jacob
Component: Generic views Version:
Severity: normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I'm developing my Django programs under Windows, which is set to local time, the time zone being Europe/Berlin. When I set TIME_ZONE in my settings.py to 'Europe/Berlin' Django sets the offset to GMT to zero (determined by item.date|date:"d.m.Y H:i O" in a template) and the time returned by datetime.now() is one hour earlier then it is on my computer (the time shown in the log, e.g. [26/Dec/2005 ...] is also one hour too early). The only way of correcting it, seems to set TIME_ZONE to 'GMT-1', which is not true for Germany (and does not respect daylight saving).

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by adrian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of other time-zone related tickets.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.