Code

Opened 5 years ago

Closed 5 years ago

#10680 closed (duplicate)

contrib.comments documentation for customisation does not work

Reported by: jakub_vysoky Owned by: nobody
Component: contrib.comments Version: master
Severity: Keywords: comments doc
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I tried to go through the docs/ref/contrib/comments/custom.txt and I found out, that it cannot work. There is CommentWithTitle that inherits from BaseCommentAbstractModel, but the CommentFormWithTitle inherits from CommentForm.

CommentWithTitle should inherit from Comment, or there should be some sort of BaseCommentAbstractForm.

I've attached the second solution.

There is a git branch as well: http://github.com/HonzaKral/django/tree/new-comments

Attachments (1)

comments-doc-10278.diff (7.4 KB) - added by jakub_vysoky 5 years ago.
BaseCommentAbstractForm for contrib.comments

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by jakub_vysoky

BaseCommentAbstractForm for contrib.comments

comment:1 Changed 5 years ago by jakub_vysoky

  • Component changed from Uncategorized to django.contrib.comments
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 5 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10559

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.