Code

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10679 closed (worksforme)

SessionBase loses multiple values for list when encoding QueryDict objects

Reported by: tymofiy Owned by: nobody
Component: contrib.sessions Version: 1.0
Severity: Keywords:
Cc: akhavr@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The testcase:

from django.http import QueryDict
from django.conf import settings
settings.configure(DEFAULT_CHARSET='UTF-8')
q = QueryDict('city=1&city=2')
q
# <QueryDict: {u'city': [u'1', u'2']}>
from django.contrib.sessions.backends.base import SessionBase
s = SessionBase()
str = s.encode(q)
s.decode(str)
s
# <QueryDict: {u'city': [u'2']}>

Reproducable in 1.0 and Trunk.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Alex

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

This looks like what was fixed in r10240, what version are you testing against?

comment:2 Changed 5 years ago by Alex

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce: http://dpaste.com/21804/

comment:3 Changed 5 years ago by tymofiy

  • Version changed from SVN to 1.0

Actually yes, works fine in Trunk.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.