Code

Opened 5 years ago

Closed 5 years ago

#10536 closed (duplicate)

Broken file-like object on upload

Reported by: chris@… Owned by: nobody
Component: File uploads/storage Version: 1.0
Severity: Keywords: seek
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

File-like objects should support a third argument to the seek() method called whence, which specifies where-abouts to start seeking from (relative/absolute/end-of-file). Because Django's implementation is broken for uploaded files, I cant do this:

myzip = ZipFile(self.myfile)

inside the save() method of my model. Please see Python's documentation for file-like objects, and specifically the seek() method in that documentation (pydoc file).

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by ramiro

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm pretty sure this is a duplicate of #10047

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.