Opened 6 years ago

Closed 6 years ago

#10535 closed (duplicate)

No Exception is thrown or output when fixtures are not found

Reported by: peterbraden Owned by: nobody
Component: Testing framework Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When a unit test is run with fixtures that do not exist, no error is reported, and thus tests fail for un-obvious reasons.

When setting up tests it is desirable to know about any shortcomings of the tests. It is desired therefore that a traceback is recorded when a bad fixture is specified similar to when an error is thrown when loading the fixtures.

Change History (3)

comment:1 Changed 6 years ago by peterbraden

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

It seems this is down to the verbosity being set to 0:

call_command('loaddata', *self.fixtures, {

'verbosity': 0,
'commit': False
})

I haven't got time to test/write patch within the next few weeks, but is seems it should be as simple as turning verbosity to 1.

comment:2 Changed 6 years ago by lgs

This looks like a duplicate of #10200

comment:3 Changed 6 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10200

Note: See TracTickets for help on using tickets.
Back to Top