Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#10371 closed Uncategorized (invalid)

Outdated piece in Tutorial pt. 2

Reported by: michaelw Owned by: nobody
Component: Documentation Version: 1.0
Severity: Normal Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: no UI/UX: no

Description

Regarding: http://docs.djangoproject.com/en/dev/intro/tutorial02

Tabularline seems to have been renamed to Tabularline

and

Stackedeline to Stackedeline

Attachments (2)

highlights.png (19.8 KB) - added by michaelw 8 years ago.
highlighted text, maybe this makes it more obvious
working.png (25.7 KB) - added by Russell Keith-Magee 8 years ago.
Screenshot of what the last comment should look like.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by Russell Keith-Magee

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: invalid
Status: newclosed

I can't see what you're referring to. Tabularline and Stackedeline haven't ever been used by Django, and I can't find any reference to them in the docs. TabularInline and StackedInline are used in tutorial 2, but those names are accurate (and have been for some time).

Unless you can provide more specific details as to what you think is wrong, I'm marking this invalid.

comment:2 Changed 8 years ago by michaelw

The code in the tutorial does'nt work,

class ChoiceInline(admin.Tabularline):
...

will yield an error since there is no admin.Tabularline

from django.contrib import admin
dir(admin)

['AdminSite', 'HORIZONTAL', 'ModelAdmin', 'StackedInline', 'TabularInline', 'VERTICAL', 'builtins', 'doc', 'file', 'name', 'path', 'autodiscover', 'helpers', 'models', 'options', 'site', 'sites', 'util', 'widgets']

comment:3 Changed 8 years ago by Russell Keith-Magee

Again - I can't find anywhere that says "Tabularline". The only section of Tutorial 2 that talks about tabular layout is the following:

Django offers a tabular way of displaying inline related objects; you just need to change the ChoiceInline declaration to read:

class ChoiceInline(admin.TabularInline):
    #...
With that TabularInline (instead of StackedInline), the related objects are displayed in a more compact, table-based format:

This correctly tells you to use Tabular*In*line, not Tabularline. Where are you seeing Tabularline?

Changed 8 years ago by michaelw

Attachment: highlights.png added

highlighted text, maybe this makes it more obvious

comment:4 Changed 8 years ago by michaelw

Maybe the attachment helps.

I had a typo in the ticket creation, i meant to say:

TabularInline seems to have been renamed to Tabularline

Changed 8 years ago by Russell Keith-Magee

Attachment: working.png added

Screenshot of what the last comment should look like.

comment:5 Changed 8 years ago by Russell Keith-Magee

It does help - it shows me that there is something very very wrong with your browser.

I've attached a screenshot of what my last comment should look like. I have no idea what is going on here, but your browser and/or font is eating "In"s. The raw HTML for this page contains Tabular*In*line, so something is going wrong with the rendering at your end.

comment:6 Changed 8 years ago by michaelw

Haha, true.

Sorry for bothering.

comment:7 Changed 5 years ago by anonymous

Easy pickings: unset
Severity: Normal
Type: Uncategorized
UI/UX: unset

This is caused by the browser add-on Binnen-I Be Gone. Since Stacked-Inline and Tabular-Inline have "In" in the middle of the word, the add-on thinks they're German words that use nonstandard grammar and tries to fix them.

Note: See TracTickets for help on using tickets.
Back to Top